re = /(?:.+?)(.{6}<em>.+?<\/em>.{6})(?:.+)/m
str = 'шла Саша по шоссе и <em>сосала</em> сушку, или что-то другое'
subst = '...$1...'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result