#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\D*\d+\D+)\d+"
Local $sString = "messages_0_items_0_data_0" & @CRLF & _
"messages[0][items][0][data][0]"
Local $sSubst = "$11"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)