// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\D*\d+\D+)\d+").unwrap();
let string = "messages_0_items_0_data_0
messages[0][items][0][data][0]";
let substitution = "$11";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}