re = /^(\D*\d+\D+)\d+/m
str = 'messages_0_items_0_data_0
messages[0][items][0][data][0]'
subst = '$11'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result