using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\D*\d+\D+)\d+";
string substitution = @"$11";
string input = @"messages_0_items_0_data_0
messages[0][items][0][data][0]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}