const regex = /^(\D*\d+\D+)\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\D*\\d+\\D+)\\d+', 'gm')
const str = `messages_0_items_0_data_0
messages[0][items][0][data][0]`;
const subst = `$11`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);