package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\D*\d+\D+)\d+`)
var str = `messages_0_items_0_data_0
messages[0][items][0][data][0]`
var substitution = "$11"
fmt.Println(re.ReplaceAllString(str, substitution))
}