use strict;
my $str = 'messages_0_items_0_data_0
messages[0][items][0][data][0]';
my $regex = qr/^(\D*\d+\D+)\d+/mp;
my $subst = '$11';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";