import Foundation
let pattern = #"^(\D*\d+\D+)\d+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
messages_0_items_0_data_0
messages[0][items][0][data][0]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$11"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)