using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@BindView\((?<id>.*?)\)\W+(?<type>.*?)\W+(?<name>.*?)\W";
string substitution = @"var ${name}: ${type} = findViewById(${id})";
string input = @"@BindView(R.id.tab_layout) TabLayout tabLayout;";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}