import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@BindView\\((?<id>.*?)\\)\\W+(?<type>.*?)\\W+(?<name>.*?)\\W";
final String string = "@BindView(R.id.tab_layout) TabLayout tabLayout;";
final String subst = "var ${name}: ${type} = findViewById(${id})";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}