$re = '/@BindView\((?<id>.*?)\)\W+(?<type>.*?)\W+(?<name>.*?)\W/m';
$str = '@BindView(R.id.tab_layout) TabLayout tabLayout;';
$subst = "var ${name}: ${type} = findViewById(${id})";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;