re = /@BindView\((?<id>.*?)\)\W+(?<type>.*?)\W+(?<name>.*?)\W/m
str = '@BindView(R.id.tab_layout) TabLayout tabLayout;'
subst = 'var ${name}: ${type} = findViewById(${id})'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result