import re
regex = re.compile(r"@BindView\((?<id>.*?)\)\W+(?<type>.*?)\W+(?<name>.*?)\W", flags=re.MULTILINE)
test_str = "@BindView(R.id.tab_layout) TabLayout tabLayout;"
subst = "var ${name}: ${type} = findViewById(${id})"
result = regex.sub(subst, test_str)
if result:
print(result)