// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)@BindView\((?<id>.*?)\)\W+(?<type>.*?)\W+(?<name>.*?)\W").unwrap();
let string = "@BindView(R.id.tab_layout) TabLayout tabLayout;";
let substitution = "var ${name}: ${type} = findViewById(${id})";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}