import Foundation
let pattern = #"@BindView\((?<id>.*?)\)\W+(?<type>.*?)\W+(?<name>.*?)\W"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"@BindView(R.id.tab_layout) TabLayout tabLayout;"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"var ${name}: ${type} = findViewById(${id})"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)