# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)(http|https|ftp|ftps)(\:\\/\\/[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,})(\\/[^#]*|)(#(\S*)|)(.*)/<a href='$2$3$4' target='$6'>$2$3$4$5<\/a>/gm;t' <<< "Здесь ссылка должна быть в теге <a> https://example.info/ru/task#g конец текста"