re = /(.*)(http|https|ftp|ftps)(\:\/\/[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,})(\/[^#]*|)(#(\S*)|)(.*)/m
str = 'Здесь ссылка должна быть в теге <a> https://example.info/ru/task#g конец текста'
subst = '<a href=\'$2$3$4\' target=\'$6\'>$2$3$4$5</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result