#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*)(http|https|ftp|ftps)(\:\/\/[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,})(\/[^#]*|)(#(\S*)|)(.*)"
Local $sString = "Здесь ссылка должна быть в теге <a> https://example.info/ru/task#g конец текста"
Local $sSubst = "<a href='$2$3$4' target='$6'>$2$3$4$5</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)