import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)(http|https|ftp|ftps)(\\:\\/\\/[a-zA-Z0-9\\-\\.]+\\.[a-zA-Z]{2,})(\\/[^#]*|)(#(\\S*)|)(.*)";
final String string = "Здесь ссылка должна быть в теге <a> https://example.info/ru/task#g конец текста";
final String subst = "<a href='$2$3$4' target='$6'>$2$3$4$5</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}