package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)(http|https|ftp|ftps)(\:\/\/[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,})(\/[^#]*|)(#(\S*)|)(.*)`)
var str = `Здесь ссылка должна быть в теге <a> https://example.info/ru/task#g конец текста`
var substitution = "<a href='$2$3$4' target='$6'>$2$3$4$5</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}