use strict;
my $str = 'Здесь ссылка должна быть в теге <a> https://example.info/ru/task#g конец текста';
my $regex = qr/(.*)(http|https|ftp|ftps)(\:\/\/[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,})(\/[^#]*|)(#(\S*)|)(.*)/mp;
my $subst = '<a href=\'$2$3$4\' target=\'$6\'>$2$3$4$5</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";