const regex = /(.*)(http|https|ftp|ftps)(\:\/\/[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,})(\/[^#]*|)(#(\S*)|)(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)(http|https|ftp|ftps)(\\:\\\/\\\/[a-zA-Z0-9\\-\\.]+\\.[a-zA-Z]{2,})(\\\/[^#]*|)(#(\\S*)|)(.*)', 'gm')
const str = `Здесь ссылка должна быть в теге <a> https://example.info/ru/task#g конец текста`;
const subst = `<a href='$2$3$4' target='$6'>$2$3$4$5</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);