$re = '/(.*)(http|https|ftp|ftps)(\:\/\/[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,})(\/[^#]*|)(#(\S*)|)(.*)/m';
$str = 'Здесь ссылка должна быть в теге <a> https://example.info/ru/task#g конец текста';
$subst = "<a href='$2$3$4' target='$6'>$2$3$4$5</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;