import Foundation
let pattern = ##"(.*)(http|https|ftp|ftps)(\:\/\/[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,})(\/[^#]*|)(#(\S*)|)(.*)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"Здесь ссылка должна быть в теге <a> https://example.info/ru/task#g конец текста"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href='$2$3$4' target='$6'>$2$3$4$5</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)