# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*)(http|https|ftp|ftps)(\:\/\/[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,})(\/[^#]*|)(#(\S*)|)(.*)"
test_str = "Здесь ссылка должна быть в теге <a> https://example.info/ru/task#g конец текста"
subst = "<a href='$2$3$4' target='$6'>$2$3$4$5</a>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.