# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([0-9]{11}).+?(\s*[0-9].+)/$1xxxxxxxxxxxxxxxxxxxx$2/gm;t' <<< "01234567890Alice Stone 3978 Smith st...
01234567890Alice Stone3978 Smith st..."