re = /([0-9]{11}).+?(\s*[0-9].+)/m
str = '01234567890Alice Stone 3978 Smith st...
01234567890Alice Stone3978 Smith st...'
subst = '$1xxxxxxxxxxxxxxxxxxxx$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result