import Foundation
let pattern = #"([0-9]{11}).+?(\s*[0-9].+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
01234567890Alice Stone 3978 Smith st...
01234567890Alice Stone3978 Smith st...
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1xxxxxxxxxxxxxxxxxxxx$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)