const regex = /([0-9]{11}).+?(\s*[0-9].+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9]{11}).+?(\\s*[0-9].+)', 'gm')
const str = `01234567890Alice Stone 3978 Smith st...
01234567890Alice Stone3978 Smith st...`;
const subst = `$1xxxxxxxxxxxxxxxxxxxx$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);