#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([0-9]{11}).+?(\s*[0-9].+)"
Local $sString = "01234567890Alice Stone 3978 Smith st..." & @CRLF & _
"01234567890Alice Stone3978 Smith st..."
Local $sSubst = "$1xxxxxxxxxxxxxxxxxxxx$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)