using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]{11}).+?(\s*[0-9].+)";
string substitution = @"$1xxxxxxxxxxxxxxxxxxxx$2";
string input = @"01234567890Alice Stone 3978 Smith st...
01234567890Alice Stone3978 Smith st...";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}