$re = '/([0-9]{11}).+?(\s*[0-9].+)/m';
$str = '01234567890Alice Stone 3978 Smith st...
01234567890Alice Stone3978 Smith st...';
$subst = "$1xxxxxxxxxxxxxxxxxxxx$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;