// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([0-9]{11}).+?(\s*[0-9].+)").unwrap();
let string = "01234567890Alice Stone 3978 Smith st...
01234567890Alice Stone3978 Smith st...";
let substitution = "$1xxxxxxxxxxxxxxxxxxxx$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}