package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]{11}).+?(\s*[0-9].+)`)
var str = `01234567890Alice Stone 3978 Smith st...
01234567890Alice Stone3978 Smith st...`
var substitution = "$1xxxxxxxxxxxxxxxxxxxx$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}