#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[8]*(?:1[8]*[8]?0|0[8]*[8]?1)[8]*\b"
Local $sString = "0188" & @CRLF & _
"0818" & @CRLF & _
"0881" & @CRLF & _
"1088" & @CRLF & _
"1808" & @CRLF & _
"1880" & @CRLF & _
"8018" & @CRLF & _
"8081" & @CRLF & _
"8108" & @CRLF & _
"8180" & @CRLF & _
"8801" & @CRLF & _
"8810" & @CRLF & _
"01" & @CRLF & _
"801" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")