use strict;
my $str = '0188
0818
0881
1088
1808
1880
8018
8081
8108
8180
8801
8810
01
801
';
my $regex = qr/\b[8]*(?:1[8]*[8]?0|0[8]*[8]?1)[8]*\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}