$re = '/\b[8]*(?:1[8]*[8]?0|0[8]*[8]?1)[8]*\b/m';
$str = '0188
0818
0881
1088
1808
1880
8018
8081
8108
8180
8801
8810
01
801
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);