using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[8]*(?:1[8]*[8]?0|0[8]*[8]?1)[8]*\b";
string input = @"0188
0818
0881
1088
1808
1880
8018
8081
8108
8180
8801
8810
01
801
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}