re = /\b[8]*(?:1[8]*[8]?0|0[8]*[8]?1)[8]*\b/m
str = '0188
0818
0881
1088
1808
1880
8018
8081
8108
8180
8801
8810
01
801
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end