// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[8]*(?:1[8]*[8]?0|0[8]*[8]?1)[8]*\b").unwrap();
let string = "0188
0818
0881
1088
1808
1880
8018
8081
8108
8180
8801
8810
01
801
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}