# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b[8]*(?:1[8]*[8]?0|0[8]*[8]?1)[8]*\b"
test_str = ("0188\n"
"0818\n"
"0881\n"
"1088\n"
"1808\n"
"1880\n"
"8018\n"
"8081\n"
"8108\n"
"8180\n"
"8801\n"
"8810\n"
"01\n"
"801\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.