package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[8]*(?:1[8]*[8]?0|0[8]*[8]?1)[8]*\b`)
var str = `0188
0818
0881
1088
1808
1880
8018
8081
8108
8180
8801
8810
01
801
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}