const regex = /\b[8]*(?:1[8]*[8]?0|0[8]*[8]?1)[8]*\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[8]*(?:1[8]*[8]?0|0[8]*[8]?1)[8]*\\b', 'gm')
const str = `0188
0818
0881
1088
1808
1880
8018
8081
8108
8180
8801
8810
01
801
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}