# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\$_(.*?)\['(.*?)'\]/$this->\L$2->$1\('\U$2\')/g;t' <<< "$_POST['INPUT']"