import Foundation
let pattern = #"\$_(.*?)\['(.*?)'\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"$_POST['INPUT']"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$this->\L$2->$1\('\U$2\')"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)