#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\$_(.*?)\['(.*?)'\]"
Local $sString = "$_POST['INPUT']"
Local $sSubst = "$this->\L$2->$1\('\U$2\')"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)