import re
regex = re.compile(r"\$_(.*?)\['(.*?)'\]")
test_str = "$_POST['INPUT']"
subst = "$this->\\L$2->$1\\('\\U$2\\')"
result = regex.sub(subst, test_str)
if result:
print(result)