package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$_(.*?)\['(.*?)'\]`)
var str = `$_POST['INPUT']`
var substitution = "$this->\L$2->$1\('\U$2\')"
fmt.Println(re.ReplaceAllString(str, substitution))
}