const regex = /\$_(.*?)\['(.*?)'\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$_(.*?)\\[\'(.*?)\'\\]', 'g')
const str = `\$_POST['INPUT']`;
const subst = `$this->\L$2->$1\('\U$2\')`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);